Quick Tips

  • All permissions must be allowed when downloading the app

  • Phone must be the latest version

  • Profile information must be accurate

  • The Do Not Disturb feature must be disabled

Phone Versions

As of November 2022, device versions older than the ones mentioned below are not compatible.

iPhone

  • iOS 13

  • iOS 14

  • iOS 15

  • iOS 16

Android

  • Android 10

  • Android 11

  • Android 12

  • Android 13

Contact Us

Thanks For Submitting!

If you are having further issues, feel free to Contact us above. Our team of experts will contact you immediately. Or                      to communicate with our support bot